Jump to content
thirty bees forum

Can't make an order anymore (redirects to address)


Recommended Posts

Hi. Yesterday I realized that if I added custom fields to the products and buy one with text+file and then another without custom text nor file, in the cart when I tried to erase one of the products, my cart turned empty. If I went buying the same product in the cart appeared the old items and something really didn't go well.

So, I tried to upgrade to 1.1.x in a test store and that problem didn't happened. Then I upgraded my no-test store (not yet in production, but next to).

Now when I add something to the cart and try to finish the order, it redirects me to change my address. And I cannot do anything to pass that step, it continues saying something is missing (the telephone, but I give it both).

I don't know how to use debug mode to know that's happening.


Link to comment
Share on other sites

Reading the code of the form, I found this:

<div class="required dni form-group unvisible" style="display: none;">
        <label for="dni">Número de indentificación fiscal <sup>*</sup></label>
        <input class="is_required form-control" data-validate="isDniLite" type="text" name="dni" id="dni" value="">
        <p class="help-block">DNI / NIF / NIE</p>


I don't know why now is requiring that, I'm trying to figure out where to choose what fields are required.

Link to comment
Share on other sites

The last one, with pictures. If I show the hidden input field (adding 'block' to display) I can see it's required. I found that in the country there is a switch to turn it on and off, but it's off.

Is there other place? Why is it hidden if it's required?


Captura de pantalla -2020-05-14 22-44-51.png

Captura de pantalla -2020-05-14 22-45-10.png

Link to comment
Share on other sites

17 hours ago, datakick said:

It's not required, it just looks like it. But that doesn't really matter, because it's hidden 🙂Do you get any errors regarding DNI field when saving the address?

Oh, I see. :)

No, no DNI errors. It just reload the same page to edit my address. I tried to Add a new address (from user's addresses) and it's saved OK. I have two address now, but when It is suppoused to go to "pedido?step=1" it goes to address edition.

I tried making a new account, but it's the same.


Link to comment
Share on other sites

More information. I placed a backup of the same shop but 1.1.0 version and the checkout works well. If I go to Core Updater and update to 1.1.x it starts redirecting to Modify Adress.

What do you recommend? I updated because of an error with custom fields, and I prefer to use the last version if it's what's mostly used.

I tried going back to 1.1.0 with Code Updater and it works again.

Link to comment
Share on other sites

Thanks for the answer.

I don't see any unusual in web server logs.

For 'log in thirtybees/logs', do you mean see the content of that directory with the shell, for example? There are two errors, but they're old. 

Link to comment
Share on other sites

Well, I finally understood what's going on. In Stable it did get passed through the first step, but then appeared "No available carriers for that address" error.

I realize that the Zone 'South America' was disabled, because I was trying days ago to make a local Zone with one city name. After enabling again that Zone and make it work on Stable I upgraded again to Bleeding Edge and now I can end the buying.

It was strange that there were no error, but there was one...

Thanks for the help, after reading about versions in other thread I really wanted to be en bleeding's last 1.1.x without issues numbers.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...