Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
oliiix

Bleeding Edge Update Fails / Module Updates fail Request to https://www.dmn.tld/shp/admin/index.…51b83a&action=processCompare&ajax=1 failed with status 'rejected'. controller.js:210:13

Question

I have some trouble with updates of modules and shop. I tried to update a clone of my shop to a bleeding edge version to try the new geolocation module I'm in dire need of 😉 I'm currently on 1.1.0. But updating the shop or modules doesn't seem to work anymore so to test this further I also installed fresh copies of 1.0.8 and 1.1.0 but it's everywhere the same for some month now. Updating isn't possible anymore. Here you can find some probably related errors.

Fresh Shop Installations succeed with following errors (TB V 1.0.8 & 1.1.0)

An error occurred during installation...

This is a non-fatal error. It can be fixed in Backoffice later. Just jot it down or make a screenshot to not forget it now, or look it up in logs/ later.

  1. Translations for English (English) and thirty bees version 1.0.8 not found.
  2. Translations for thirty bees version 1.0.7 not found either.
  3. Translations for English (English) not installed.
  4. No translations pack available for your version.
  5. Translations for Deutsch (German) and thirty bees version 1.0.8 not found.
  6. Translations for thirty bees version 1.0.7 not found either.
  7. Translations for Deutsch (German) not installed.
  8. No translations pack available for your version.

Happens with 1.0.8 and 1.1.0 ofc with 1.1.0 the version numbers are different. Back in time when switching to TB I never ever had any installation problems, warnings or errors.

Shop Update with Core Updater

So I thought I read somewhere that the issue for the maxmind module is 823 so i chose this issue and clicked compare in the core updater. Comparison sometimes works, most of the time the first time it doesn't and shows below error. Also if it does work the same error also appeares everytime when clicking on update.

Error: Request to https://www.domain.tld/shop/admin/index.…51b83a&action=processUpdate&ajax=1 failed with status 'rejected'. controller.js:210:13

Modules

I cannot update modules for some time now. There's no error messages in debug mode.

Steps and what they lead to (all in backend->modules):

  • Doing module update:
    bootstrap success-message appears that says it's been updated, but version still the same and the module in the module list still shows the update button instead of configure or whatever.
  • Installing module that isn't yet in the modules folder:
    3 errors
    -
    thirty bees Updater: There was an error while extracting the module file (file may be corrupted).
    - Module not found
    - Module Block Links cannot be upgraded: Error while extracting the latest version.
  • Uploading and installing a module zip file via the backend interface, if it's an update or doesn't exist yet:
    Works like a charm, it uploads it, unzips it, installs it, i can configure it, everything good. So all this doesn't look like folder/file permission problems. I installed some birthday module and the latest core updater version without problems.

Problems exist with all core updater versions.

Conclusion

Seems like it's server related or a bug. Maybe it's got problems retrieving stuff from the git repository, downloads broken packages even or there's some bug in unzipping the package? Because sometimes comparing works and sometimes is says there's a js problem while using the same issue as comparison. I think wakabayashi already said everythings running fine for him so maybe there's really some server settings that need to be adjusted. What makes me believe more in a server settings issue is that 1.0.8 for sure was working fine until I switched to 1.1.0 and this version updated fine as well in the beginning if I remember correctly. And I updated quite a lot of modules without any problems. And now fresh installations of 1.0.8 and 1.1.0 all have the same problems. So this leads me to believe that some server settings have been changed. I'll also ask my hoster if there was any server related updates, but as I can't remember how long this problem exists, it might be hard to pin point a guilty one 🙂 If someone has an idea what could be responsible here please share 😄

-----------------

What it also cannot load is bootstrap-sortable:

Error: The resource from “https://raw.githubusercontent.com/drvic10k/bootstrap-sortable/1.11.2/Scripts/bootstrap-sortable.js” was blocked due to MIME type (“text/plain”) mismatch (X-Content-Type-Options: nosniff). en

... but I think that's not related? Strange though as I have set the mime type for js as application/javascript on my server so not sure where this text/plain comes from... Or should I set my servers mime definition to text/plain? But that wouldn't be so good I think?^^

System: Apache 2.4, PHP 7.1

Thanks a lot!

Oli

Edited by oliiix

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I have a feeling that your server is configured to block downloading assets from internet

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Yes I'm still checking some things, just got rid of all blocked ip which wasn't the problem. What strangely was working was an update to the same shop version which actually added 2 new files, that was working strangely but when choosing an issue it's not working, is there any big difference between the "links" used to get the stable data and the bleeding edge data? Is there anyway to download the issue as zip or something so i can update the files by extracting them myself on the server? Couldn't find the issue on github... Thanks a lot for your help!

Share this post


Link to post
Share on other sites
  • 0

this looks weird. Could you give me back office and ftp access to your test server, so I could investigate?

Updater module should be the most stable piece if the system, but it obviously isn't. That needs to be fixed

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...