Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
papagino

Just migrated from PS 1.6 using the migration tool and now I have a blank screen in Backoffice and online store...

Question

Hi, I just migrated from PS 1.6 using the migration tool and now I have a blank screen for both backoffice and website.

This is for a online webstore that's been online for many years.

I turned PS_MODE_DEV to true and I get this:

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home4/amaxmed1/public_html/classes/Tools.php on line 5303

Fatal error: Access level to Link::getLangLink() must be public (as in class LinkCore) in /home4/amaxmed1/public_html/override/classes/Link.php on line 192

 

Host currently setup with PHP 7.3

Please help, I don't want to do a restore yet, if I can get it to work with your help.

Dan

EDIT:

After doing the migration with the latest thirty bees migration module, I did a refresh...

The Migration module updates to thirty bees 1.0.8, could it be that this version is not PHP 7.3 ready?

I am currently doing a Restore, and will try again, this time following the instructions specified below:

    - Uninstall the migration module, psonesixmigrator.
    - Install thirty bees’ update module, tbupdater.
    - Update all the modules in need of an update, one by one. Boring, but necessary.
    - Install Core Updater (coreupdater), thirty bees’ next generation updater.
    - Use Core Updater to update thirty bees further. Migration module updates to thirty bees 1.0.8 only, then Core Updater takes over.

 

... Fingers crossed.

EDIT #2

I performed a Restore from my server restore option and also restored the database created just before doing the migration.

Now, I am back to my previous Prestashop Backoffice 1.6.1.xx, everything works EXCEPT the modules tab, whenever I try to access the modules section on my backoffice, I get a "BLANK" page. Turn on Dev mode and no error is shown???

Did I just BREAK my 8 years old online shop permanently???

The main reason I wanted to migrate to TB is for the PHP 7.3-7.4 support because my Host is no longer offering older version of PHP and some of my modules stop to work properly after PHP version went up.

Any help would be greatly appreciated.

 

God, I am starting to really regret this...

Dan

 

 

 

 

 

 

 

Edited by papagino

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

I think for now, I will have my site moved to the new host where PHP 7.2 is supported.

This way, I will be back online to take orders.

I will deal with the other stuff later...

Cheers

 

Share this post


Link to post
Share on other sites
  • 0

I've bought modules from him before. He is a good egg! I hope he has thrirtybees module replacements for you.

Did I mention you should have tested backups and backups of the backups tested before you even attempt this?

 

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, papagino said:

I think for now, I will have my site moved to the new host where PHP 7.2 is supported.

This way, I will be back online to take orders.

I will deal with the other stuff later...

Cheers

 

This will make it even worse if you do nothing as php 7.2 is EOL and php 7.3 will be EOL on Dec 6th 2021. I hope your server is locked down good...

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, Billy said:

This will make it even worse if you do nothing as php 7.2 is EOL and php 7.3 will be EOL on Dec 6th 2021. I hope your server is locked down good...

I agree, but what is better, having a shop open for business with and EOL PHP version, or a shop that is currently not operational and loosing thousand $$$ per week?

As I said, this will give me time to setup a brand new ThirtyBees shop with new refresh theme and modules while still being able to operate my shop...

Share this post


Link to post
Share on other sites
  • 0

I hear ya but who said anything about closing your website? Your website should remain open until finial import into new.yourshop.com. Then move website...

Share this post


Link to post
Share on other sites
  • 0

Oh and I didn't even do that as I only had 12 orders in-between. In which I had all the paypal info of those orders. I could have just entered those 12 orders manually into my website but I chose not to. This is what I meant by finial import. 

 

Share this post


Link to post
Share on other sites
  • 0
18 minutes ago, Billy said:

I hear ya but who said anything about closing your website? Your website should remain open until finial import into new.yourshop.com. Then move website...

My current website is in Catalog mode now (No shopping options) since September 22nd, because of the bug with my payments modules caused by my host changing to PHP 7.3. So this is why I have to move it to the new Host that support older PHP versions so to have my shop running again...

Right now, I can take orders via email from my existing customers who are contacting me to place orders and I create PayPal invoice that I send to their emails.

But the site won't work for new customers...

Also, I use a separate invoicing system for all orders, online is just a way to accept orders and I supply receipts to customers via my offline invoicing system.

Cheers

Edited by papagino

Share this post


Link to post
Share on other sites
  • 0

I would strongly advice to use the services of someone more used with PS and TB for your issue before you funk up your website even more.

It's probably a trivial bug but it must be dealt with with attention.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, the.rampage.rado said:

I would strongly advice to use the services of someone more used with PS and TB for your issue before you funk up your website even more.

It's probably a trivial bug but it must be dealt with with attention.

Thanks for your inputs, at this point, I don't really care about the prestashop site, as it has been to much worked on and modified.

I want to start fresh with TB as the migration did not work for me, even if it showed successful, the backoffice site crashed immediately after I refresh the Backoffice page.

I have a question for you, is it possible to have 2 sites sharing the same database with one in maintenance mode?

Thanks for all your help.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...