Jump to content
thirty bees forum
  • 0

Litespeed cache module stopped working today out of nowhere



As I was pumping products in my shop suddently I started seeing 500 in FO on many pages.

Then I tried deleting htaccess - no success. Tried deleting my litespeed cache and system cache and started seeing 500 on all FO pages.

Googling the issue I stumbled on https://github.com/litespeedtech/lscache_prestashop/issues/44

I'm running my shop on php7.4 and it was not changed. I'm unable to run higher php because my theme is not compatible and also my slider poops everywhere.

Any advise what could be causing this sudden issue?

The error log from the server:

#6 /home/uXXX/public_html/xxxbulgaria.com/modules/litespeedcache/classes/VaryCookie.php(101): LiteSpeedCacheVaryCookie->__construct in /home/uXXX/public_html/site1.com/classes/db/DbPDO.php on line 148
#5 /home/uXXX/public_html/site1.com/modules/litespeedcache/classes/VaryCookie.php(76): LiteSpeedCacheVaryCookie->init(Object(Context), Object(Cookie))
#4 /home/uXXX/public_html/site1.com/modules/litespeedcache/classes/VaryCookie.php(234): CountryCore::getIsoById(236)
#3 /home/uXXX/public_html/site1.com/classes/Country.php(249): DbCore->getValue(Object(DbQuery))
#2 /home/uXXX/public_html/site1.com/classes/db/Db.php(801): DbCore->getRow('SELECT `iso_cod...', true)
#1 /home/uXXX/public_html/site1.com/classes/db/Db.php(774): DbCore->query('SELECT `iso_cod...')
#0 /home/uXXX/public_html/site1.com/classes/db/Db.php(477): DbPDOCore->_query('SELECT `iso_cod...')
2023-01-07 18:18:47.452798 [NOTICE] [3438596] [T0] [IP:port:HTTP2-1#APVH_site1.site.eu:443] [STDERR] PHP Fatal error:  Uncaught Error: Call to a member function query() on null in /home/uXXXX/public_html/site1.com/classes/db/DbPDO.php:148
2023-01-07 18:18:47.452761 [NOTICE] [3438596] [T0] [IP:port:HTTP2-1#APVH_site1.site.eu:443] [STDERR] PHP Notice:  Undefined property: DbPDO::$link in /home/uXXX/public_html/site1.com/classes/db/DbPDO.php on line 148
2023-01-07 18:18:47.452758 [NOTICE] [3438596] [T0] [IP:port:HTTP2-1#APVH_site1.site.eu:443] [STDERR] PHP Warning:  collectlogs: failed to log error: Call to a member function query() on null in /home/uXXX/public_html/site1.com/modules/collectlogs/classes/CollectorLogger.php on line 140
2023-01-07 18:18:47.452749 [NOTICE] [3438596] [T0] [IP:port:HTTP2-1#APVH_site1.site.eu:443] [STDERR] PHP Notice:  Undefined property: DbPDO::$link in /home/uXXX/public_html/site1.com/classes/db/DbPDO.php on line 148


Edited by the.rampage.rado
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

This is nice bug. Calling __destruct on connection instance make this instance unusable, but does not remove it from connection pool.

Sequence like this would fail:

Db::getInstance(_PS_USE_SQL_SLAVE_)->execute('select * from table');

Tracked in issue https://github.com/thirtybees/thirtybees/issues/1600

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...