Jump to content
thirty bees forum

Error when creating Pack of Existing Products

Ian Ashton

Recommended Posts

When creating a pack of existing products I get a Quantities (500 error) on clicking Save and Stay. See attached file.

I can do this on my local server and get the failure when running at my ISP ( Fasthosts in the UK )

Checked the error log on the server and found an error ( see attached file ) which relates to a disabled function 'set_time_limit'.

I assume this is a restriction set by my ISP but not sure if there's a workaround?

This is the only time I've come across this error.

Anyone any ideas?

Thirty bees version: 1.4.0

PHP Build 8.0

MySQL 5.6.51



Link to comment
Share on other sites

I believe this is causes by some module. There are only a few places in the core that call this function, and none of them is in the product controller area.

Anyway, a lot of modules (for example modules to synchronize data or that generate feeds) uses on this function, because default 30seconds might not be enough.

If your hosting provider can't disable this, I would consider changing server.


Link to comment
Share on other sites

FWIW - after more investigation

1. Creating/editing a pack worked with Thirtybees 1.4/PHP 7.4

2. Creating a pack fails on Thirtybees 1.4/PHP 8.0 (see original post)

system errorlog message

[Thu Aug 31 12:15:06.678767 2023] [fcgid:warn] [pid 98599] [client] mod_fcgid: stderr: Tried to use set_time_limit which is a disabled function, this is not allowed., referer: https://ashtonjones.uk/index.php

exception log in Thirtybees log folder 

*ERROR*     2023/08/31 - 12:16:18: Error: Cannot use positional argument after named argument at line 665 in file classes/stock/Warehouse.php

3. Creating a pack of products with products NOT in advanced stack control works. 

As I'm running a system I ported over from Prestashop 1.6.24 I'm wondering if I'm looking at a Thirtybees problem or one that's specific to my service?

So - setup test system from virgin 1.4 release and test data ( on a raspberry pi !! )

edited product to move them to Advanced Stock Management and created a pack.

Seemed to work OK but as soon as I add the pack to my default warehouse I get the on screen error on clicking SAVE.


Link to comment
Share on other sites

Looks like PHP8 issue.

Try to edit file /classes/stock/Warehouse.php line 665, and change

$res = call_user_func_array('array_intersect', $list);


$res = call_user_func_array('array_intersect', array_values($list));

Let me know if that helped -- if so, I will add this to bleeding edge.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...