Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
basix101

Updater v.1.3.3 "thirty bees' caching features are disabled"

Question

I am trying to update TB from v.103 to v.1.0.7 using TB Updater but I cannot disable thirty bees' caching features!

I have tried disabling all caching but nothing seems to work.

Any ideas?

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

@basix101 said in Updater v.1.3.3 "thirty bees' caching features are disabled":

Edit: The "Update Thirty Bees" button is missing because of the disable cache error!

Edit file /config/settings.inc.php, find line with _PSCACHEENABLED_ and change it to look like this:

define('_PS_CACHE_ENABLED_', '0');

Note that this constant is not used anymore tb core, but tbupdater module still use it to determine if the cache is turned on/off

Share this post


Link to post
Share on other sites
  • 0

I'm having the same problem. My settings.inc.php already looks as described, but the updater still says "thirty bees' caching features are disabled"

Share this post


Link to post
Share on other sites
  • 0

I have the same problem with tbupdater v.1.4.0 and cache is disabled in settings.inc.php: define('PSCACHEENABLED', '0'); if this constant is not used anymore, why not just remove the check in the tbupdater module?

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, elund said:

I have the same problem with tbupdater v.1.4.0 and cache is disabled in settings.inc.php: define('PS_CACHE_ENABLED', '0'); if this constant is not used anymore, why not just remove the check in the tbupdater module?

This check has already been fixed

If it shows this warning for you, it really means you have server cache enabled on your server.

Edited by datakick

Share this post


Link to post
Share on other sites
  • 0

Yes, sorry - server side caching was still activated for my shop

Share this post


Link to post
Share on other sites
  • 0

The same problem here: define('_PS_CACHE_ENABLED_', '0'); already in my file.

Do I disalbe the cache settings on my server? To get the option to upgrade from v1.3 to 1.8?

Share this post


Link to post
Share on other sites
  • 0

Caching are fixing, but I receive the follow error:

All files upgraded. Now upgrading database...

[Ajax / Server Error for action upgradeDb] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " "

Share this post


Link to post
Share on other sites
  • 0

After upstarted:

I receive a blank screen with the follow message:

[PrestaShop] Fatal error in module file :/home/erolust/public_html/modules/graphnvd3/graphnvd3.php:
Access level to GraphNvD3::$_width must be protected (as in class ModuleGraphEngine) or weaker

Share this post


Link to post
Share on other sites
  • 0

I think there are something going wrong, now, when I tray to login to the backoffice, I receive a blank page.

Share this post


Link to post
Share on other sites
  • 0

Since you have upgraded from 1.0.3, you need to delete old stats modules, as described here:

Go to your modules directory and DELETE all of your stats module except statsdata and statsmodule. Also delete the modules graphnvd3, gridhtml, pagesnotfound, and sekeywords.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks datakick, all works again!

Some icones are gone, but I will seek for these again on a later time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×