Jump to content
thirty bees forum

Cant' access modules page


Recommended Posts

Hello, This morning I've attempted a migration to thirty bees from Prestashop and something failed. It looks like disabling non native modules and overrides from the migration module does not work and it should be done from Advanced Parameters - Performance. The problem was a third part Google Authenticator module: when I attempted login after the migration I couldn't access to the back office and all problems started there. I had to install a backup, but after that I couldn't access anymore to the modules page. I also did a server rewind and modules page still shows blank. I've enabled debug mode and I got no errors, just the same blank page. So now I can't access Prestashop's modules page so I can't try migration again. Configuration parameters are ok:

PHP version 7.1.22

Memory limit 768 M

Max execution time 300

MySQL version 10.1.35-MariaDB-cll-lve

MySQL engine InnoDB

Any ideas of what can cause this error?

Link to comment
Share on other sites

Blank page means there's some fundamental problem, like a PHP syntax error. Such errors get reported to the Apache/Nginx log (/var/log/apache2/error.log or similar).

If you have an idea which module causes this, remove it from the modules folder and try again. Like none mkdir modules.off mv modules/dirtymodule modules.off/ Modules in modules/ still get partially executed when listing modules, even if they're neither installed nor enabled.

And we'd be interested in which module caused the trouble, of course. The migrator is about to get a feature automatically moving some known-to-be-troublesome modules aside.

Link to comment
Share on other sites

Thanks for your prompt reply. I've found two errors under home/public_html/logs: *ERROR* 2018/10/06 - 14:16:33: Class 'Gauthenticator' not found at line 31 in file override/controllers/admin/AdminLoginController.php *ERROR* 2018/10/06 - 09:38:32: Shop not found at line 404 in file classes/shop/Shop.php The involved module is Google Authenticator. By the way, I've removed it from /modules and the blank page still is there. Also, as I've restored a backup previous to this morning migration attempt, it makes no sense to have an error produced after the backup was made. I will try a complete server rewind. But I was wondering if it could be a Prestashop api addons problem. Some time ago they had such issue, but then I got a 404 error instead of a blank page.

Link to comment
Share on other sites

Thank-you Lesley, it worked. I'll explain what I did for if it happens it can help someone else: I've installed the database and backup of Prestashop manually in cPanel.

I've disabled non native modules and overrides under Andvanced Parameters - Performance, and I've disabled cache there too. I've also put the store in maintenance mode. When I've finished, i've disabled, deleted and uninstalled Google Authenticator module and I've done the migration to thirty bees again, also disabling there third party modules and overrides through the buttons in the migration module.

When I was done I got a 500 error in the back office, so I could not access it. Then I've deleted the Google Authenticator override AdminLoginController.php file in override/controllers/admin/AdminLoginController.php. It was still there after having deleted the module.

After that I've gained access to the back office, but I've encountered three other problems when trying to display the modules list. I've got a fatal error and warning "Access level to GraphGoogleChart::$_width must be protected (as in class ModuleGraphEngine) or weaker". I've solved it making the following changes:

modules/Googlechart/Googlechart.php Change: private $width; private $height; private $values; private $legend; private $_titles;

For: protected $width; protected $height; protected $values; protected $legend; protected $_titles;

modules/Grafvisfire/Grafvisfire.php Change: private $xml; private $values = NULL; private $legend = NULL; private $titles = NULL;

For: private $xml; protected $values = NULL; protected $legend = NULL; protected $titles = NULL;

modules/GraphXmlSwfCharts/GraphXmlSwfCharts.php Chante: private $xml; private $values = NULL; private $legend = NULL; private $legendmore = ''; private $titles = '';

For: private $xml; protected $values = NULL; protected $legend = NULL; private $legendmore = ''; protected $titles = '';

After those changes, I could access the modules list. I continue exploring the installation to see if everything is ok now or if I need a little bit more of editing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...