Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
Havouza

Module stop working after update to 1.0.8

Question

I have transferred our shop 1.0.8 to a new VPS. When we should import some new products with the normal module we use, BA importer it gives a 500 error. I thought something is missing in the OP in the new VPS but I then switched back to the old one and it get the same error. We never imported some products after the update so this is cause by updating from 1.0.3 to 1.0.8 using the Core Updater. Below the error code from Apache and the event log from the shop.

[Thu May 02 09:10:51.612350 2019] [proxy_fcgi:error] [pid 14964] [client 162.158.88.3:23094] AH01071: Got error 'PHP message: PHP Warning:  simplexml_load_string(): Entity: line 1: parser error : Start tag expected, '<' not found in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 583\nPHP message: PHP Warning:  simplexml_load_string(): \xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbdN\xef\xbf\xbd0\x0c\xef\xbf\xbd\xef\xbf\xbd{\xef\xbf\xbd*\xef\xbf\xbd5\xef\xbf\xbd@\b\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbdLH\xef\xbf\xbd!4\x1e\xef\xbf\xbd$n\x1b\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\x83\xef\xbf\xbdD\x13\x12\x0c\xef\xbf\xbd\xef\xbf\xbd\xc3\x8eq~\x7f\xef\xbf\xbdb\xef\xbf\xbd\xef\xbf\xbdLn,\xef\xbf\xbd0&K^\xef\xbf\xbdUY\xef\xbf\xbd\x02\xef\xbf\xbd&c}\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbdqy/6\xcd\xa2~ in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 583\nPHP message: PHP Warning:  simplexml_load_string(): ^ in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 583\nPHP message: PHP Notice:  Trying to get property 'Relationship' of non-object in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 585\nPHP message: PHP Warning:  Invalid argument supplied for foreach() in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 585\n', referer: https://www.jv74.se/admin123jv74/index.php?controller=AdminModules&token=ce198036a69a035c871909399e1ec7da&configure=ba_importer&tab_module=quick_bulk_update&module_name=ba_importer

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
parser error : Start tag expected, '<' not found

Looks like you are trying to import invalid XML file

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I have the same module and the same problem.  Unfortunately, you need to use the core updater and go back to version 1.0.7.  

I mentioned it in this thread:

I recently tried 1.0.8 again after I saw that there was an update to ba_importer and I had to revert back once again to TB 1.0.7 as the issue is not fixed.  Everything works fine and normally under 1.0.7.

Edited by movieseals

Share this post


Link to post
Share on other sites
  • 0

Well I have tested with 11 different ones that worked absolutely 100% before the update so I doubt that that is the problem

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, movieseals said:

I have the same module and the same problem.  Unfortunately, you need to use the core updater and go back to version 1.0.7.  

I recently tried 1.0.8 again after I saw that there was an update to ba_importer and I had to revert back once again to TB 1.0.7 as the issue is not fixed.  Everything works fine and normally under 1.0.7.

Why not use bleeding edge, as this issue (and then some) is already fixed there?

Share this post


Link to post
Share on other sites
  • 0

No I get the same result in both 1.0.7 and bleeding edge

And Apche error log flooded

[Thu May 02 15:39:11.738392 2019] [proxy_fcgi:error] [pid 12492] [client 162.158.89.176:50686] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n', referer: https://www.jv74.se/admin123jv74/index.php?controller=AdminCoreUpdater&token=e1c920c671b60e00308af7677de93829
[Thu May 02 15:39:14.884595 2019] [proxy_fcgi:error] [pid 13264] [client 162.158.89.176:57788] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n', referer: https://www.jv74.se/admin123jv74/index.php?controller=AdminLogin&token=e5edd5c2124bac83c8c8d72b0f8b897a&redirect=AdminCoreUpdater
[Thu May 02 15:39:20.855321 2019] [proxy_fcgi:error] [pid 13244] [client 141.101.105.25:58682] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n'
[Thu May 02 15:39:27.212129 2019] [proxy_fcgi:error] [pid 13237] [client 172.69.226.78:27040] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n', referer: http://www.host-thirty.com
[Thu May 02 15:39:28.781254 2019] [proxy_fcgi:error] [pid 13401] [client 162.158.89.176:31610] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n', referer: https://www.jv74.se/admin123jv74/index.php?controller=AdminCoreUpdater&token=e1c920c671b60e00308af7677de93829
[Thu May 02 15:39:31.083644 2019] [proxy_fcgi:error] [pid 13411] [client 162.158.89.176:36964] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n', referer: https://www.jv74.se/admin123jv74/index.php?controller=AdminModules&token=ce198036a69a035c871909399e1ec7da
[Thu May 02 15:39:31.869727 2019] [proxy_fcgi:error] [pid 13411] [client 162.158.89.176:36964] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n', referer: https://www.jv74.se/admin123jv74/index.php?controller=AdminModules&token=ce198036a69a035c871909399e1ec7da
[Thu May 02 15:39:48.568008 2019] [proxy_fcgi:error] [pid 13181] [client 172.69.63.64:25624] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n', referer: https://www.jv74.se/
[Thu May 02 15:39:56.948545 2019] [proxy_fcgi:error] [pid 13573] [client 162.158.89.176:38090] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\nPHP message: PHP Warning:  simplexml_load_string(): Entity: line 1: parser error : Start tag expected, '<' not found in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 583\nPHP message: PHP Warning:  simplexml_load_string(): \xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbdN\xef\xbf\xbd0\x0c\xef\xbf\xbd\xef\xbf\xbd{\xef\xbf\xbd*\xef\xbf\xbd5\xef\xbf\xbd@\b\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbdLH\xef\xbf\xbd!4\x1e\xef\xbf\xbd$n\x1b\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\x83\xef\xbf\xbdD\x13\x12\x0c\xef\xbf\xbd\xef\xbf\xbd\xc3\x8eq~\x7f\xef\xbf\xbdb\xef\xbf\xbd\xef\xbf\xbdLn,\xef\xbf\xbd0&K^\xef\xbf\xbdUY\xef\xbf\xbd\x02\xef\xbf\xbd&c}\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbdqy/6\xcd\xa2~ in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 583\nPHP message: PHP Warning:  simplexml_load_string(): ^ in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 583\nPHP message: PHP Notice:  Trying to get property 'Relationship' of non-object in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 585\nPHP message: PHP Warning:  Invalid argument supplied for foreach() in /home/jv74/public_html/modules/ba_importer/libs/simplexlsx.class.php on line 585\n', referer: https://www.jv74.se/admin123jv74/index.php?controller=AdminModules&token=ce198036a69a035c871909399e1ec7da&configure=ba_importer&tab_module=quick_bulk_update&module_name=ba_importer
[Thu May 02 15:40:03.119076 2019] [proxy_fcgi:error] [pid 13237] [client 162.158.89.176:51332] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n', referer: https://www.jv74.se/admin123jv74/index.php?controller=AdminModules&token=ce198036a69a035c871909399e1ec7da
[Thu May 02 15:40:15.556866 2019] [proxy_fcgi:error] [pid 13396] [client 162.158.74.202:11742] AH01071: Got error 'PHP message: PHP Deprecated:  The each() function is deprecated. This message will be suppressed on further calls in /home/jv74/public_html/vendor/smarty/smarty/libs/sysplugins/smarty_internal_compilebase.php on line 75\n'
 

Share this post


Link to post
Share on other sites
  • 0

1.0.34. Its long time since support was gone but I had no real urg to spend another 70 euro to have new version

It worked perfect until I updated the TB

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, movieseals said:

@datakick  I tried Bleeding Edge but it broke other things.

What other things? Did you file issue or reported it here on forum??? You know that bleeding edge is going to be released soon, so this is really a best time to report bugs

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

From the error messages you are getting, it looks like it is coded in outdated PHP.  Which version of PHP are you using on your site?

 

If I was you, I would still check if there are new updates available in your account.  Sometimes, even if the period for support has passed (I hate this system!), they update the modules nevertheless, especially when there are PHP issues.   I would definitely take a look.

Edited by movieseals

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, datakick said:

What other things? Did you file issue or reported it here on forum??? You know that bleeding edge is going to be released soon, so this is really a best time to report bugs

It breaks mostly third party modules, lots of them support has expired for.  I guess as things progress, this is something we will see more and more of.  There are so many improvements needed to basic functions and we are stuck relying on so many modules, so it is just a matter of time before everything breaks... 😞

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

I run 7.2 on the new one. It was 7.0 on the old one when it worked perfect

Share this post


Link to post
Share on other sites
  • 0

From eventlog
*ERROR*     2019/05/02 - 15:39:56: Worksheet 1 not found. at line 76 in file modules/ba_importer/libs/simplexlsx.class.php

Share this post


Link to post
Share on other sites
  • 0

One problem is that you have no way to know if a module works in Tb until you have bought and tested it

Share this post


Link to post
Share on other sites
  • 0

I have 7.0.17 on the old server and I get the same error

 

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, Havouza said:

I have 7.0.17 on the old server and I get the same error

 

Did you look in your prestashop account if there was an update to a new version?

Share this post


Link to post
Share on other sites
  • 0

There is no updates. I bought the module first half 2017

Share this post


Link to post
Share on other sites
  • 0

Downgraded to 1.0.7 and installed the module. Now it works normal until the importstep. Its only 5 products in the sheet but it hange on import 0/5 until I break it off. Same result for excel file and csv.

No error in log

Hints?

Share this post


Link to post
Share on other sites
  • 0

You are running PHP 7.2?  I had to go back to 7.1 for things to run smoothly on my install.

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, Havouza said:

ok will install 7.1. Thanks

Let me know if it does not improve things.

Share this post


Link to post
Share on other sites
  • 0

No, something happened so I have to rollback the snapshot. But it will sort it out. 

Thanks for the help so far.
The probem seems to be to get php 7.1 on Ubuntu 18.04

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×