Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
mikemania

Installation Assistant compatibility check, nothing listed

Question

Posted (edited)

Doing a fresh install of TB 1.0.8 and getting stuck on the 3rd step. I'm asked to "correct the item(s) below", but nothing is listed.

Running php 7.2

Could it be permissions?

Edited by mikemania

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

We had quite a number of cases where uploaded distribution files turned out to be incomplete. So, a first step would be to upload all of them again to find out whether things work better then.

If this still doesn't help, I'd appreciate getting access to your webhosting, so I can try myself. Such errors are very rare, don't want to miss the opportunity to catch it.

Share this post


Link to post
Share on other sites
  • 0

I'm the same. Xilo.net is a very fast server for the money but does not install TB 1.1 and TB 1.08 after coping with TB 1.07.

If there are any questions I should ask their support team, just let me know or ask for logon details.
John

Share this post


Link to post
Share on other sites
  • 0

What plan do you have and how are you trying to install it? Like automatic installer or uploaded? I want to get an account with them and test. 

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Traumflug is going to look into my server space, but if you want a separate account i will refund you the first year's £30 for the cheapest shared hosting on xilo.net

Their help desk writes "Does the install script rely on using phpinfo for server information by any chance as we block this on the servers for security.

Please let us know if that isn't the case and we can certainly look in to this further for you."

best
John
 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Reason found: Xilo.net, the server company write

Quote
...allow_url_fopen is blocked for security.
At the moment, there is no way around this but with a few changes we're making internally on the servers, we hope this may be possible in the next coming weeks.

TB 1.07 installs & core updater module updates
TB 1.08 has an error message on a yellow stripe with a red cross after it,

  • Required PHP parameters
  • PHP's 'allow_url_fopen' enabled: fail

TB 1.1 has no error message with a chance of red-herring searches if an optional error shows instead, as on this thread

 

Edited by veganline
& core updater module updates

Share this post


Link to post
Share on other sites
  • 0

Did you try to edit php.ini, like I described in an email to you?

No idea which kind of "security issue" they have in mind, it's just a shortcut for more complex web requests. One can easily write code doing the same without this feature enabled, and most of thirty bees' code already does. thirty bees 1.0.7 doesn't test for it on installation, still uses it in a few places.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Yes, I tried allow_url_fopen = On in the php.ini file among all the other likely things and then turned it off again before asking for help!

The 1.07 installer worked, and the core update module then updated to 1.1, so all OK.
My xilo.net server is the odd bit. It's very fast and cheap but I had to install a database for another program via an app installer - Installatron - before the TB1.07 installer recognized it.

Edited by veganline
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...