Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

cprats

Top menu issue: no subcategories drop-down

Recommended Posts

I've just updated several modules, and block top menu has a fault: after the update, subcategories do not drop-down. If maximum level depth is not set to 2, main categories also disappear from the menu and only links persist.

Under block categories, also updated, dynamic option is set to Yes.

Any suggestions?

Thank-you.

Share this post


Link to post
Share on other sites
2 hours ago, cprats said:

I've just updated several modules, and block top menu has a fault: after the update, subcategories do not drop-down. If maximum level depth is not set to 2, main categories also disappear from the menu and only links persist.

Under block categories, also updated, dynamic option is set to Yes.

Any suggestions?

Thank-you.

Indeed, the new version of blocktopmenu doesn't work correctly. You should downgrade to version 3.0.2

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I also had some problem after updating blocktopmenu and downgaraded to 3.0.2 ....
Tks to @datakick ... new version 3.04 works perfect!

Edited by ariom
  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the confirmation.

My test also suggests that all issues are solved, so I've officially released 3.0.4. Hopefully not many people upgraded to faulty 3.0.3 yet. 

  • Like 1

Share this post


Link to post
Share on other sites
12 minutes ago, datakick said:

Thanks for the confirmation.

My test also suggests that all issues are solved, so I've officially released 3.0.4. Hopefully not many people upgraded to faulty 3.0.3 yet. 

Hello again,

I've just seen your posts here, and I've updated the module to 3.0.4 from back office. It works perfectly now. Thank-you very much.

Share this post


Link to post
Share on other sites

Hello again @datakick

After yesterday's upgrade to 3.0.4 the drop-down menu worked fine, but today it doesn't work anymore, without having touched anything.

Share this post


Link to post
Share on other sites

I've downgraded to 3.0.2 and it worked. I've upgraded to 3.0.4 again, I've cleared the cache, and it stopped working.

Share this post


Link to post
Share on other sites

Weird. If you PM me access to your back office I can have a look

 

Share this post


Link to post
Share on other sites

Thank-you. I've just sent you access details through PM

Share this post


Link to post
Share on other sites

The problem was found. There's a new configuration option named Maximum level depth

When you install this module from scratch, it is initialized to value 2. But when you upgrade from previous version it has value 0, thus displaying only top-level entries. When you add non-zero value it works as expected.

image.png.b266e0e227bcaecc7e3bbc326c30749e.png

  • Like 2

Share this post


Link to post
Share on other sites

For me it does not work. Level depth is set at 4 but I cannot add categories to the menu.blocktopmenu.thumb.png.b84c2d63ad603dd16c10d5ca2bb98301.pngcategories.thumb.png.6646543768989e4d6b0aca06ffdc3260.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...