Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
Havouza

No attributes for virtual products/services

Question

I have not realized before but it is not possible to have attributes selling virtual products or services. Wonder why?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Yes, it's defined. It's _DB_PREFIX_, defined in config/settings.inc.php. PrestaShop has the same definition, so no excuses to not use this definition properly :-)

Share this post


Link to post
Share on other sites
  • 0

But then it must be crap coding, because when it crashes it does it because the sql is pscombinationdownload ......... That table does dot exist because it is created as tb_comb....... and so on

Share this post


Link to post
Share on other sites
  • 0

Strange, that SQL query should take the DBPREFIX_ but it uses ps_. OK the developer will hopefully solve the problem

Share this post


Link to post
Share on other sites
  • 0

But then it must be crap coding

Happens often. Sometimes due to sloppiness, sometimes due to laziness, sometimes due to a lack of knowledge.

Share this post


Link to post
Share on other sites
  • 0

OK. Now I will add some more mystery on the table. Just to be sure when I contacted the developer I installed a fresh PS 1.6.1.11. During installation I changed the Db prefix to tb_. But after installing the module it worked flawlessly also with the Db prefix as it should do. But why not the other way round

Share this post


Link to post
Share on other sites
  • 0

So to conclude. The module brake the tbshop if the DBPREFIX is tb_. A tb-shop with ps_ prefix works without a problem. A PS shop works without a problem with both prefixes Suggestions anyone?

Share this post


Link to post
Share on other sites
  • 0

@Havouza said in No attributes for virtual products/services:

So to conclude. The module brake the tbshop if the DBPREFIX is tb_. A tb-shop with ps_ prefix works without a problem. A PS shop works without a problem with both prefixes Suggestions anyone?

I think this should be put in bug reports because if the db_prefix doesn't work, it may also not work with other modules.

Share this post


Link to post
Share on other sites
  • 0

I will first hear what the developer say. I am sure it a module problem. I have found a couple of others that is in the PS shop also

Share this post


Link to post
Share on other sites
  • 0

If they solve the problem that problem dont have to be solved until later by tb

Share this post


Link to post
Share on other sites
  • 0

Just got back at the office, you guys are working on weekends ? ;-)

Please let me know what the dev says, i'm very anxious to give this a try :-)

Thanks ! Great find !

Share this post


Link to post
Share on other sites
  • 0

It is no problems anymore. works perfect. My test shop crashed the first time but it must have been some other reason. I restored it and installed the module again without problem

Share this post


Link to post
Share on other sites
  • 0

I've just tried to install it but it crashed at first then the second time I got this:

Parse error: syntax error, unexpected '{', expecting function (T_FUNCTION) in /Applications/XAMPP/xamppfiles/htdocs/tbquebecamerique/classes/module/Module.php(1859) : eval()'d code on line 22 [PrestaShopException]

Class ProductOverrideOriginal_remove593e9ebf16602 does not exist at line 1860 in file classes/module/Module.php

Share this post


Link to post
Share on other sites
  • 0

Strange. Mine worked flawless when I installed. I hope you have a backup

Share this post


Link to post
Share on other sites
  • 0

It's only my desktop dev installation no worries.

I know why.. it is because I had some of the same files already in the override folder and it breaks it, can't install if files are there already. Renamed mine and I could install.. but now i cant log to update it, says this domain is already associated with another account :-/

Share this post


Link to post
Share on other sites
  • 0

meaning he see what domain he is on. But not everyone has emails from the domain they use. fex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...