Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
Janvier

Not seeing 'Lazy load images' and 'Enable webp images' in admin

Question

10 answers to this question

Recommended Posts

  • 0

Your theme doesn't support it. You need to have:

<lazy_load>1</lazy_load>
<high_dpi>1</high_dpi>
<webp>1</webp>

At the bottom of your themes config.xml right before the last line which is . Then the theme needs to be actually coded for it to work.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

That would explain that then. That's unfortunate, I would have liked to try webp images. I'm using Warehouse theme. Thanks for explaining

Share this post


Link to post
Share on other sites
  • 0

I added values to theme config.xml and /config/xml/themes/(theme name).xml

But i'm still unable to see option in admin image area for enabling lazy load.

Cache cleaned..

Any solution for enabling lazy load in admin area after own theme changes for supportig lazy load?

Share this post


Link to post
Share on other sites
  • 0

Figured it out..

After adding values to theme xml to both config files i found, there is a xml name mismatch.

 

After changing /config/xml/themes/(theme name).xml to proper name, it work.

Share this post


Link to post
Share on other sites
  • 0
On 1/12/2019 at 7:42 PM, SLiCK_303 said:

Then the theme needs to be actually coded for it to work.

Could you explain what it means that the theme needs to be coded for webp to work? 

About the <webp>1</webp> property, is it TB specific or does it exist on PS? Thanks

Share this post


Link to post
Share on other sites
  • 0
On 5/14/2020 at 2:47 PM, romaric17 said:

Could you explain what it means that the theme needs to be coded for webp to work? 

About the <webp>1</webp> property, is it TB specific or does it exist on PS? Thanks

 It's specific to TB....

Share this post


Link to post
Share on other sites
  • 0

Ok, thanks. How could a theme not support webp images?

What do the <webp>1</webp> themes have that others don't?

 

Share this post


Link to post
Share on other sites
  • 0
25 minutes ago, romaric17 said:

What do the <webp>1</webp> themes have that others don't?

webp enabled themes have webp support

Share this post


Link to post
Share on other sites
  • 0

That is clear. But what does it mean that such themes support webp? What kind of features have to be added to a non webp-enabled theme?

Share this post


Link to post
Share on other sites
  • 0

For that you should open template files which do show pictures and compare them to non webp enabled theme. (product.tpl, product-list-item.tpl and others).

You will quickly notice the difference.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...