Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
Smile

Regenerating images 5xx error.

Question

I am regenerating new images in Webp, but i get the following error after 1810 pictures and the process stops.

"Received a 5xx response (generic error). Make the rate limit of the server has been (temporarily) increased"

The error keeps popping up but after few hours still just 181 pictures. Probably a big picture. How to find out which picture or how te set the server better?

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Have you turned on debug mode in Admin to see if it generates a error

Edited by AndyC

Share this post


Link to post
Share on other sites
  • 0

Yes did that, no errors shown except from this one. 

Share this post


Link to post
Share on other sites
  • 0

Prestools.com is a free separate program that works on the same photos while they're on your server. I found it worth the time trying to learn what it does, if only for the display of information.

According to the manual - section 13.2 - it is another way of regenerating photos on your server, and so maybe worth a try for that reason as well.

Edited by veganline

Share this post


Link to post
Share on other sites
  • 0

Yes this could be a solution. But I am more into fixing it as a core issue...

Although... maybe this is the best as quick fix....

 

How the error looks attached.

Untitled-1.jpg

Share this post


Link to post
Share on other sites
  • 0

Your server throws some 5xx error, and we can't help you unless we know what it is. You can look into browser javascript console, in Network tab, and look for these 500 error responses. They should contain some more information

Share this post


Link to post
Share on other sites
  • 0

PHP settings are as follows:

; cPanel-generated php ini directives, do not edit
; Manual editing of this file may result in unexpected behavior.
; To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
; For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)

allow_url_fopen = On
allow_url_include = Off
display_errors = Off
enable_dl = Off
file_uploads = On
max_execution_time = 1000
max_input_time = -1
max_input_vars = 20000
memory_limit = 2048M
post_max_size = 1024M
session.gc_maxlifetime = 1440
session.save_path = "/var/cpanel/php/sessions/ea-php71"
upload_max_filesize = 512M
zlib.output_compression = Off
opcache.enable=0

I changed the max_execution_time from 120 to 1000, but the error kicks in just after 1-2 minutes.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Smile said:

Seems to be a 500 error.

500 error 1.JPG

Close, but not enough... we need to see what's in the response body

Share this post


Link to post
Share on other sites
  • 0

Well seems the execution time while in the php.ini it is set to 1000.... Maybe somewhere in the VPS it is overruled?

Row 363 is red.

 ThirtyBeesException
Maximum execution time of 120 seconds exceeded
in file classes/ImageManager.php at line 363
Source file: classes/ImageManager.php

344:        // Author: Tim Eckel - Date: 09/07/07 - Version: 1.1 - Project: FreeRingers.net - Freely distributable - These comments must remain.
345:        //
346:        // Optional "quality" parameter (defaults is 3). Fractional values are allowed, for example 1.5. Must be greater than zero.
347:        // Between 0 and 1 = Fast, but mosaic results, closer to 0 increases the mosaic effect.
348:        // 1 = Up to 350 times faster. Poor results, looks very similar to imagecopyresized.
349:        // 2 = Up to 95 times faster.  Images appear a little sharp, some prefer this over a quality of 3.
350:        // 3 = Up to 60 times faster.  Will give high quality smooth results very close to imagecopyresampled, just faster.
351:        // 4 = Up to 25 times faster.  Almost identical to imagecopyresampled for most images.
352:        // 5 = No speedup. Just uses imagecopyresampled, no advantage over imagecopyresampled.
353:
354:        if (empty($srcImage) || empty($dstImage) || $quality <= 0) {
355:            return false;
356:        }
357:        if ($quality < 5 && (($dstW * $quality) < $srcW || ($dstH * $quality) < $srcH)) {
358:            $temp = imagecreatetruecolor($dstW * $quality + 1, $dstH * $quality + 1);
359:            imagecopyresized($temp, $srcImage, 0, 0, $srcX, $srcY, $dstW * $quality + 1, $dstH * $quality + 1, $srcW, $srcH);
360:            imagecopyresampled($dstImage, $temp, $dstX, $dstY, 0, 0, $dstW, $dstH, $dstW * $quality, $dstH * $quality);
361:            imagedestroy($temp);
362:        } else {
363:            imagecopyresampled($dstImage, $srcImage, $dstX, $dstY, $srcX, $srcY, $dstW, $dstH, $srcW, $srcH);
364:        }
365:
366:        return true;
367:    }
368:
369:    /**
370:     * Generate and write image
371:     *
372:     * @param string   $type
373:     * @param resource $resource

 

Share this post


Link to post
Share on other sites
  • 0

Finally found it, could not change it in php.ini or cpanel, or .htacces, had to do it in user.ini

Thanks all!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...