Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
Mark

Only Free Delivery is possible, whats wrong?

Question

Hello, I cant get permanently rid of Free Shipping. I cant launch my site until its sorted. Ive tried a lot of testing nothing seems to work.

 

I have a delivery charge listed in "Additional shipping fees (for a single item)" in the product menu that I want the delivery charge to be.

  

Under Shipping/ Carriers  Free Shipping is No as is Handling.

 

No matter what I do, the cart always shows free delivery

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1
1 hour ago, Mark said:

Thanks, Good rationale, but the problem remains.

I have just one carrier, called "test" . It does not have Free Shipping.

The products do not have Free Shipping either.

 There's basically nothing that tells it this is free shipping, but it is free nonetheless.

Ive been waiting about 2 weeks to get this launched, do you think I should give up if it cant get basics like shipping right?

Screenshot_2019-05-28 Carriers • Product Solutions NZ.png

This looks like a bug in thirtybees core, or some override is messing around.

If you send me ftp access, and back office access, I can have a look into this for you.

Share this post


Link to post
Share on other sites
  • 0

Shipping is complicated and it is easy to do something wrong. The standard algorithm is to put the cheapest "carrier" first. So if there is a free option - even when it is retrieve in shop - it will come out on top. However, there is a page where you can change that sorting algorithm. 

Share this post


Link to post
Share on other sites
  • 0

Thanks, Good rationale, but the problem remains.

I have just one carrier, called "test" . It does not have Free Shipping.

The products do not have Free Shipping either.

There's basically nothing that tells it this is free shipping, but it is free nonetheless.

Ive been waiting about 2 weeks to get this launched, do you think I should give up if it cant get basics like shipping right?

Screenshot_2019-05-28 Carriers • Product Solutions NZ.png

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

There really should be a debug mode... that shows us all the calculations at the cart when its in debug mode.... Its taking days to get this sorted... It might have something to do with Geolocation, sometimes its working without that on, sometimes not.

Edited by Mark

Share this post


Link to post
Share on other sites
  • 0

Just for the benefit of anyone else experiencing this problem and reading this for answers, @datakick very kindly got to the bottom of this in a private message when he said:

"The problem is with misconfiguration. 

You checked 'I want to use the advanced stock management' option on your products. But you didn't create any warehouse, and didn't associate your products with any warehouse. 

That means that thirtybees will not find any carrier for product --> it can't calculate shipping costs --> shipping cost is zero --> cart displays free shipping.

When you disable this option, thirtybees will not try to find carries that can deliver from given (non-existing) warehouse. Instead, it will use standard mechanism to find carrier (based on zone/country), and everything will work correctlyl "

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...