Jump to content
thirty bees forum

Update failed Ajax error


Recommended Posts

coreupdater does not have any dependency on tbupdater. It can work without it fine.

However, without tbupdater module installed, native tb modules will not be automatically updated. So it is likely that you used some old and buggy version of coreupdater because of this.

tbupdater module is indeed internally marked as deprecated. The functionality to keep other modules update needs to be moved to core, and then we can finally stop using this module. Until that is done, though, I recommend not to uninstall this module.

Link to comment
Share on other sites

25 minutes ago, Havouza said:

The problem is that every error s always a user error never va software error. In this case I dont accept that. 

When did I wrote that this was user error? In fact, I even wrote 

3 hours ago, datakick said:

it is likely that you used some old and buggy version of coreupdater

To me that sounds like I were saying that the problem is in the software. 

I wrote that there is zero dependency between coreupdater and tbupdater. And that's the fact. I've looked inside the code of both modules to prove it. I've even tested it by deleting the tbupdater module. The coreupdater module worked absolutely fine. There is no dependency. Moreover, tbupdater modules does not implement any hook handlers, have no overrides, and all classes are in their own namespace. This means that the tbupdater module lives in absolutely isolated environment. Its code is not executed unless there an explicit interaction. And there is none in coreupdater.

Prove me wrong, delete the tbupdater module from your installation and test coreupdater to see if you reproduce the issue again

All that investigation points me to a simple conclusion -- after you installed the tbupdater module, you were able to update coreupdater to new version, which fixed your problem. Installation of tbupdater module did not fix the issue, it just enabled you you to fix it. 

2 hours ago, Havouza said:

And I always have all used modules updated to the latest

How? Without tbupdater module installed, the system would not show you that new versions are available. Did you manually check github repository of all native modules, and manually downloaded and installed the latest versions?

  • Like 1
Link to comment
Share on other sites

Again, core updater were updated BEFORE I deleted the tb updater. I then reinstalled the tbupdster and directly tested to update to 1.4 stable without any update of the core updater. So your assumption is wrong. 

You also suggest it can be a adblocker. Who has an adblocker on a dedicated webshop VPS.

But 1.4 is now installed and I assume that 1.5 will be years ahead so the problem is solved. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...