Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

violinparts

Paypal module doesn't work

Recommended Posts

After following all requirements, client id, secret id and filling out return url (in paypal) it keeps showing below even though all have been enabled (yes)

In order to provide the best checkout experience, all profiles have to be loaded and available.

Unfortunately, some profiles are missing: Website Payments Standard: Website Payments Plus: Express Checkout:

Share this post


Link to post
Share on other sites

@violinparts You are surevou use thr correct credentials? Sandbox for testing and live ones if you want to go live. If mixed up, it will not work. Many make the mistake. The module works flawless

Share this post


Link to post
Share on other sites

I got everything correct. Live, live secret key, live client key. Everything else is correct. Now it shows correctly loaded. Paypal checkout works sometimes, sometimes NOT. Website payment standard simply does not work. Looks like it is a U.S. issue.

Share this post


Link to post
Share on other sites

I have other websites using presto chango module for presta 1.6 and integrated paypal in ecommercetemplates. I did not say I used that TB module for my other sites. I just said that in those two other sites - paypal walks right from the start - no hiccup whatsoever.

Share this post


Link to post
Share on other sites

As I understand it most PS Paypal modules are built using NVP/SOAP. This is not supported by TB. The TB module is built on REST. Which seems to be what Paypal wants for the future

Share this post


Link to post
Share on other sites

This is what I see in live api calls: /v1/payment-experience/web-profiles 27 Aug 2017 03:05:38 /v1/payment-experience/web-profiles/XP-UQYK-SW7M-HJSF-VN9U 27 Aug 2017 03:05:38 /v1/payment-experience/web-profiles/XP-SJ3H-CY2Y-DK75-AUL3 27 Aug 2017 03:05:37 /v1/payment-experience/web-profiles

Paypal checkout seems to be working. But - proceed to checkout - on payment page - it simply shows this: "No payment modules have been installed."

It seems to be that is the website or module issue rather than issue with connections.

Share this post


Link to post
Share on other sites

Check modules->Payment and see if the Paypal module is activated for your currency, group, country and carrier

Share this post


Link to post
Share on other sites

Hi,

Finally it works. The payment standards finally shows up on payment page - only after I disable Website Payments Plus. Lookslike Website Payments Plus ruined it when it is enabled.

Thanks!!

Share this post


Link to post
Share on other sites

I think that comes when Paypal Payment plus is not working in your country. I had the same problem here in Cyprus

Share this post


Link to post
Share on other sites

Hello I have the same problem, the module don't appear in the checkout... I have this message: In order to provide the best checkout experience, all profiles have to be loaded and available. *Unfortunately, some profiles are missing: Website Payments Standard: Website Payments Plus: Express Checkout:

Share this post


Link to post
Share on other sites

Hello, no it's when I upgrade my store prestashop 1.6.1.18 to thirty bees, after the upgrade all it' ok but the paypal module don't work don't apper in the hook paiement order,

appear in the other hooks, like button action product or footer product, but the windows paypal don't open when I click on buttons.

I have uninstall and reinstall the module but it's the same, I'm desapointed because my official store stay on prestashop...

I've installated other store with thirtybees 1.0.3 and the paypal module work correctly...

Share this post


Link to post
Share on other sites

I'm damned! I just tested pay on my store thirty bees 1.0.3 and the paypal module don't work... I have this message:

Erreur(s) survenue(s) Authentication failed due to invalid authentication credentials or a missing Authorization header.

someone can help me?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...