Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

lovelygifts

Members
  • Content Count

    32
  • Joined

  • Last visited

Everything posted by lovelygifts

  1. lovelygifts

    Files For Updating Structured Data

    Hi sorry last few days I've not had the chance to get back on here. AHHH, what a great idea... haha, I should've thought of that really but that's brill. thanks so much.
  2. lovelygifts

    Files For Updating Structured Data

    Hi, I am going to attempt to correct some google unstructured data errors myself - however, I can't seem to find which are the files that I edit directly in my cpanel file manager. So, for example, all the unparsable structured data errors I know are syntax errors and I've used google data testing tool and can see for myself where in the file it needs amending. However, I can't see anywhere what actual file that is. Where is the HTML hard coded files in the file directory please? (This will be my last question for a while haha I hope ;) Thanks in advance. Claire https://lovely-gifts.co.uk
  3. lovelygifts

    Unstructured data invalid field types

    Hi, So I've tried to figure out how and which files I go into to fix this problem. But as I'm not coder it's thrown me. Can someone please point me in the right direction....... This is my error(s) showing in Google webmaster: Unparsable structured dataInvalid value in field "itemtype"I can see it relates to my blog posts - so assume it's somewhere in there. What do I do and what should the itemtype be please? Thanks in advance, Claire
  4. lovelygifts

    Unstructured data invalid field types

    Bless you thank you. I've been reading and researching and I got the impression that if it's not relevant, I don't need to do anything. However, agree on the working progress of the overall website is my main goal. I shall focus on the parts that urgently need attending to and try my best to figure it all out. It's great to have this forum though and people like yourselves to just clarify things sometimes, especially since I'm not web code minded. Thanks so much for your guidance. Claire.
  5. lovelygifts

    Unstructured data invalid field types

    Morning, yep done all of the above. I've started validation on Google so await the results. I've got lots of pages with warnings for missing field values such as price valid until, missing review field, missing brand etc... now, I don't have brands module enabled and I don't have expiry dates on prices of the products, therefore, do I need to concern myself with these warnings? Will they affect my ranking? If they are not relevant, should it not matter?
  6. lovelygifts

    Unstructured data invalid field types

    I know.. It's all a learning curve
  7. lovelygifts

    Unstructured data invalid field types

    Yep I've just cleared cache from back office dashboard just now but I did check the theme folder before... it says validation started so I guess I wait to see if that's fixed it right? Gosh this is so difficult haha I moved from zen cart because I thought this would be easier, which it is in many ways, but I never had these kind of errors before. ;/
  8. lovelygifts

    Unstructured data invalid field types

    So I did it and Google says this: Cannot continue validation process Affected pages were found. Fix the issue and run validation again https://lovely-gifts.co.uk/blog/4-tips-to-keep-spiders-away-naturally https://lovely-gifts.co.uk/blog/essential-oils-for-tattoo-healing https://lovely-gifts.co.uk/blog/welcome-discount-at-lovely-gifts-pieces-2019 BELOW IS WHAT I DID AS PER ADVISE - <article> <div id="sdsblogArticle" class="clearfix beesblog-post-list-item"> <div id="beesblog-before-post"> {$displayBeesBlogBeforePost} </div> <article> <div class="clearfix beesblog-post-list-item"><div id="beesblog-post-{$post->id|intval}"></div>
  9. lovelygifts

    Unstructured data invalid field types

    I will update once done and confirm if it works.
  10. lovelygifts

    Unstructured data invalid field types

    Thank you thank you thank you ;)... I found the files in my directory, it was just the rest of it haha. You are so kind. Ok I'll get that done.
  11. lovelygifts

    Unstructured data invalid field types

    ok so that doesn't work.. I've tried reading the forum's and posts on the www. but I just don't understand it. I'm too thick for this!
  12. lovelygifts

    Unstructured data invalid field types

    Would I perhaps change it to this: <div itemscope itemtype="https://schema.org/BlogPost">
  13. lovelygifts

    Unstructured data invalid field types

    Thanks so much for taking the time out to respond, it's much appreciated. I don't understand a lot of code jargon... I'm unsure as to what the fix is. I see where they are now in the files but unsure of what I'm supposed to put as itemtype and itemscope. .. thanks in advance.
  14. lovelygifts

    Unstructured data invalid field types

    My apologies. The links it relates to are https://lovely-gifts.co.uk/blog https://lovely-gifts.co.uk/blog/4-tips-to-keep-spiders-away-naturally https://lovely-gifts.co.uk/blog/essential-oils-for-tattoo-healing https://lovely-gifts.co.uk/blog/what-actually-is-aromatherapy It's the thirtybees blog module that was already installed. Thanks
  15. lovelygifts

    Homepage slider

    Hello, as I've no real experience in css / html - I am unsure of how to put the homepage slider into the middle of the page. I removed the block that was on the right when originally installed thirtybees and I'm probably missing something else out I don't know. Can someone point me in the right direction please? www.lovely-gifts.co.uk Thanks in advance. Claire
  16. lovelygifts

    Images not appearing on all pages

    Hi, so, I've been through every single section of the back office to try and find the cause of my issue - to no avail. Basically, all image folders are set to permission 755 - the images in the folders are permission 644 and assume this is correct. Strangely, where I have images appearing on say the sub-category pages, when I click a product and go onto the product info page - the image is not there! When I click where my image should be, the image pops up. So, the image is definitely there but for some reason, does not show up on all the pages. Anyways, below is the information I could find that might have something to do with this issue... however, I'm not sure what I should be doing now to get the images to appear. What am I missing here? SUB CATEGORY PAGES – · Section ID= category-subcategories. – They don’t appear here. · Div class=”thumbnail” is not appearing. · Section ID = category-products – They mostly appear here. · Left_column – New Products – Do not appear small_default Below SUB CATEGORIES is PRODUCTS – · Some images appear and others don’t. ‘home_default_smaller’ images. · category-products · product-container · product-image-container · img-responsive center-block PRODUCT INFO PAGE – · primary_block row is the div class section where there’s the main image, which is not appearing on the page unless you scroll over it – then a smaller pop up image appears. · image-block = Where product image should be showing but it isn’t. Thumbnail size 457.5px · https://lovely-gifts.co.uk/93-thickbox_default/lilac-fish-bag.jpg · large_default I've included screenshots so you can see what I mean. As far as I can tell, everything that needs to be 'activated' is so. I'm now banging my head against the wall 😕 Thanks in advance....
  17. lovelygifts

    Images not appearing on all pages

    Hi, I'm pretty sure I've no duplicate product titles, unless you mean in the actual image names, yet I don't know how to check this. I'm finding the file system a bit confusing really, especially regarding the images. The images that I upload with there product name, then does not appear as that in the file directory, instead it's something like '1128-home_default.jpg' instead of say 'Simmering Granules - Cherry', which concerns me a little because naming each product for the image should also help with search engines finding your site via the images.. yet if they are just home_default.jpg etc etc, is this not a bad thing? I can't find the images in order to check if there are any duplicates... I love thirtybees and the way my site looks, but it's not as easy to learn as Zen Cart.
  18. lovelygifts

    Images not appearing on all pages

    Hey M5150, sorry for the delay in responding. I've been busy decorating a new flat and moving and stuff. Ahh right ok, I shall have a look into that. Many thanks.
  19. lovelygifts

    Images not appearing on all pages

    Hi ya, sorry for the late response... Yep I know where to change it to friendly urls.. however, I've not resolved the issue of images not appearing. I can't afford to pay an expert to sort it out at the moment so I'm having to keep it this way for the time being. I've changed all image folders permissions so I know they are correct. I've regenerated the images and they still don't all show up. I realise the impact of not having the friendly urls, but I just have to put up with it for now. )
  20. lovelygifts

    Config File

    Hello So, I've now got my zen cart products migrated to my new thirtybees shop, which is currently in a sub-folder and now needs to be moved to the root. I tried to do this earlier but it didn't work. It appears I need to change the configuration file by removing the 'test' folder from the url so that it's just my normal shop website address lovely-gifts.co.uk. However, in admin panel, I went to advanced parameters where it has configuration details, but there is no option there to amend it. In the actual files, I headed to folder 'config' and then opened 'config.inc.php' thinking this was the one, but it's not. Can someone point me in the the right direction please? I am sooo close now and this is the final 'hurdle' to getting my thirtybees install live... Thanks in advance. Claire
  21. lovelygifts

    Images not appearing on all pages

    You are a star!! That's done it. All the images are showing up.. Is there a way around it to get the friendly urls in place as this is obviously a massive seo bonus point? If I have to have unfriendly urls so be it.. but if there's a way, it'd be great. THANK YOU THANK YOU :)
  22. lovelygifts

    Images not appearing on all pages

    I clicked the reset indexation status and this didn't do anything.. or at least, didn't fix it. I've uploaded the products csv file again and amended the image url as it had /test/ folder in the link. Uploaded but it's still not solved the problem. There must be a way to surely upload all my images again to the necessary places in the directory that they need to be in to appear on the website..? I've been really excited by thirtybees and my new shop but now I'm worried I'll have to go back to zen cart, which is good but thirtybees is much better is so many other ways.. until now. I could upload images via cpanel with zen cart if needed be - is this not possible for here?
  23. lovelygifts

    Images not appearing on all pages

    Hi ya, thanks for your response.. I needed to come away from the computer for a few hours to refresh my mind haha. So, in answer to the above, the regenerated images are showing as all of them having been done and the green coloured bar is full. I figured there was something to do with these 'thickbox_default/' in the url but can't work out why or where my images are supposed to be for it to work... if that makes sense. All 11 images are enabled for products, categories etc I was thinking of maybe importing all the products again as I originally installed them when my site was in a test folder? Also, what would happen if I click 'reset indexation status'?
  24. lovelygifts

    Images not appearing on all pages

    Hi, yes I've done that bit. Just doesn't make sense how it appears in the sub category pages but not the product info pages... it's got me bamboozled 😕
  25. lovelygifts

    Config File

    Me again... Oh I'm banging my head on a wall. Ok, so the images problem. When I was regenerating the thumbnails, error messages would come up saying either some images were corrupt or bad permissions. I've been through all the folders and checked they are the right permissions, I don't quite know what you mean by checking the images for file owners,, however, what I do do with my images generally before uploading them is unblock them and check the permission... therefore, they shouldn't be a problem. They would show up on my zen cart shop so why not on here? I tried deleting one of the products without image showing and redoing it, ensuring the image is unblocked and the right permission before uploading and the image then appears in the back office. However, still does not appear in my shop. I've done some snippets of my shop to show what I mean.. I've been through all the menu options in the back office to see if there's something else I've missed but can't fathom it. Thanks in advance. In addition: product image on some show up but then when you go into that particular product, it does not show. Upon hovering over the thirtybees default image, then product appears.. I must be missing something in the back office perhaps?
×