Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
pmfjoe

No carrier can be applied to this order

Question

Having a very odd issue when manually creating an order. All orders through the front office work perfectly. In the backoffice if I manually create an order and add 1 of any product I get the error "No carrier can be applied to this order" if I simply change the quantity to 2 or add a second product the issue goes away and the carriers appear. The issue affects all of my products in the back office only.

I have created a new test product to make sure it wasn't something on the products, tried manually assigning carriers to the product.

I have created a new carrier and set the Out-of-range behavior to Apply the highest cost in carriers.

Nothing seems to fix it. I should not this site was a clean install of thirty bees.

Any suggestions?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hello.

  • When is exactly happening that? When you save the order? When you add the product to the order?

In order to help you, some screen shoots would be appreciated. I tried to reproduce the issue, and everything went fine. So, please, give us more details to find out what is happening.

Regards!

Share this post


Link to post
Share on other sites
  • 0

If you click Add new order, select the customer, then add a product, under the shipping section you will get a message "No carrier can be applied to this order". If you change the quantity using the Up/Down arrow or add a second product then everything works as expected and the carrier list appears. It seem site specific because it works fin on another site with the same 30b version.

Share this post


Link to post
Share on other sites
  • 0

It is almost like adding the first product does not make the page refresh, but adding a second product or additional quantity does. I have tried replacing all the files in the admin section but that did not help. I will try the controller/class directories next.

Share this post


Link to post
Share on other sites
  • 0

Do you work with Stock/Warehouse? If yes all the products must have a relation with the warehouse. Go to Catalog/products/ select a product and at warehouse and select the warehouse. Check the box "stored" When you import a CSV file make a extra colum with warehouse and set it with "1" for each product.

Share this post


Link to post
Share on other sites
  • 0

Strange, Checked it same problem here in backoffice! No carier! @mdekker can you take a look what is the problem?

Share this post


Link to post
Share on other sites
  • 0

I will try that right now, it is really weird as I have 3 TB sites and only 1 is experiencing the issue.

Share this post


Link to post
Share on other sites
  • 0

For me the problem was I was using the stock John Doe as a customer. He lives in France, I don't ship to France..... As soon as I change his address, it started to work.

Share this post


Link to post
Share on other sites
  • 0

@mdekker

Sadly that does not seem to have fixed it. I don't have caching enabled at the moment but I will let it sit overnight and try again in the morning.

It is really bizarre since simply increasing the quantity resolves it, you can essentially do quantity up arrow once and then down arrow once and create the order.

Share this post


Link to post
Share on other sites
  • 0

i still dont know, i change his address to a US address and it works fine for me. I make it a France address and it doesnt work...

Share this post


Link to post
Share on other sites
  • 0

There we go, I got his France address working. I went to BO>Localization>Countries and made sure France was enabled.

Share this post


Link to post
Share on other sites
  • 0

I copied the Classes and Controller directories from a working site but that also did not resolve the issue.

Share this post


Link to post
Share on other sites
  • 0

@slick_303 Sorry, yes it is. It is weird because if you just press the quantity up arrow or add a 2nd product it resolves the issue. So I don't think it has anything to do with the shipping itself but it's more like the page isn't refreshing after the first product is added.

Share this post


Link to post
Share on other sites
  • 0

I have previously run into this problem. The most common error is the products shipping size/weight. Go to the Catalog>Products> select the product that gives the error > Shipping> check that the package width,height, depth, weight is within the range for your carriers. Also adding one product to an order that puts the whole order out of shipping size/weight for that carrier.

Share this post


Link to post
Share on other sites
  • 0

Hello all, Please make sure that you input a price range and weight range for each carrier, even if you shipping the items yourself. The ranges need to be put in order for the Carrier to become available.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

Hi.

I too am having a nightmare getting shipping to enable.
So far, this is what i've done. I've added a new zone (United Kingdom). Ive created a free shipping option and assigned it to the zone "United kingdom" and given it a price range from £0.00 - £9.99. I've tested this as a guest and also as a logged in test user and and every time I get to the check out page, I get the error "The product selection cannot be delivered by the available carrier(s). Please amend your cart."

I've tried this with the 5 step ordering process and also the single step ordering process and have the same result on both options. On the test item I have made, the carrier options are set to none based on "If no carrier is selected then all the carriers will be available for customers orders." Yet still I am unable to make any shipping method available.

Any pointers?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...