Jump to content
thirty bees forum

No Captcha reCaptcha Module not showing on one page checkout


Recommended Posts


I launched my webstore a couple of weeks ago. A customer contacted me complaining that when she tried to register at the one-page checkout, she received a message ""There is 1 Error(s): Your captcha was wrong. Please try again."

When I checked, the captcha is not shown. However, it is displaying correctly on the contact form and normal account registration form. Does anyone else encountered this problem?

Any help would be greatly appreciated.

Kind regards,


Link to comment
Share on other sites

I thought it might be something to do with the cache but the captcha isn't even displayed. I don't think there is an option to disable just on checkout but you can for the whole account registration. I have disabled it for now and see what happens. Thanks so much.

Link to comment
Share on other sites

  • 8 months later...

I also have a similar problem. When customers register a new account, the captcha is not shown and an error message is received. I tried to adjust some settings but no luck:

"If not, you might have to tweak the advanced settings. Here you can set the displayed HTML and the jQuery selector to place the captcha."

I now get mass amounts of new Russian accounts... 😞

Any suggestions are welcome.

Link to comment
Share on other sites


I ask those question because the code base is very active and it maybe helpful for people to help you with your questions.

Have you tried to upgrade to 1.08 assuming you cant update to 1.1.0 since you are on warehouse.  Although I don't know if warehouse is compatible with 1.1.0.

Did you check github?  as well did you see any issues that fit the description?  If not did you log an issue?


for the russan bot account do you have Datakick Bot blackhole plugin https://store.thirtybees.com/shop-modules/front-office/blackhole-for-bad-bots

Edited by Factor
Link to comment
Share on other sites

Hi Factor,

I tried upgrading to 1.08 and even 1.1. The upgrade to 1.08 worked, but I ran into an issue with a 'hanging' screen when making a new account. When upgrading to 1.1 the Warehouse theme was not compatible. So, I decided to stay on 1.07 for now. Did lots of customizations.

I will check the Datakick plugin, thanks!


Link to comment
Share on other sites

I tried with latest firefox and latest Chrome both of them have no issues displaying the captcha in account creation with the following settings:

1. TB side of things - only account creation, 1.1.0 and Warehouse and on other websites - edge before 1.1.0 and Warehouse

2. module side of things - yes, 0, 0, 0, 0, yes till the end.


If you switch to any number above 0 on Login attempts the captcha is shown but ignored - I had the same issue with the module - lots of Russian bot regs but it is a known bug since then. Think @datakick found out. it should be fixed soon.

Edited by the.rampage.rado
Link to comment
Share on other sites

Hi Rampage,

Thanks, I checked the settings and the Captcha shows and seems to work good with yoor provided settings, except for 1 place. When you go to the authentication page (click login upperright corner) and make a new account, it keeps telling the captcha is wrong, even when you're sure it's right (tried several times, multiple instances). 

Hope it will be fixed in future. 








Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...