Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
bhtoys

Error checking out?

Question

The product selection cannot be delivered by the available carrier(s). Please amend your cart.

I'm setting up a cart for local pick up only. I made a shipping option for that.

This is the error I get when I try to check out. I can enter all information for a Guest checkout - but that error is at the DELIVERY METHODS section. 

Share this post


Link to post
Share on other sites

25 answers to this question

Recommended Posts

  • 1

Well, the problem was that you enabled Advanced stock management, but didn't associate your products with warehouses.

After I disabled this feature checkout works just fine.

image.png.c01923e347403fa4ad8bf03209135430.png

If you want to use this feature, you need to

  1. create warehouses
  2. associate warehouses with carriers
  3. associate products with warehouses (and locations)
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Update. Now I have an error that says "No carriers available" on Section 5 of my checkout screen. 

I have carriers set up... 3 of them. 

Share this post


Link to post
Share on other sites
  • 0

Hello,  do you have set the carrier by 'weight'?  This problem is shown when weight is out of range or something like that.  Also, check your zones for shipping/pick up and also the states of countries! 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, DRMasterChief said:

Hello,  do you have set the carrier by 'weight'?  This problem is shown when weight is out of range or something like that.  Also, check your zones for shipping/pick up and also the states of countries! 

Still getting the error. Changed it to price instead of weight as well. 
I'm getting so fed up with this thing. It's not making any sense as to why it won't work. Tried multiple settings. 

Has no one else ever run into this issue?
 

Share this post


Link to post
Share on other sites
  • 0

Go to modules -> payment. and check all restrictions and payment methods.

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, yaniv14 said:

Go to modules -> payment. and check all restrictions and payment methods.

Everything is already clicked in there. 
Even took Paypal out as a payment option and bare boned payment types and shipping types. 

Share this post


Link to post
Share on other sites
  • 0

can you send a screenshot of how you setup your carrier price range?

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
46 minutes ago, yaniv14 said:

can you send a screenshot of how you setup your carrier price range?

image.thumb.png.844f32f5ebf13bdfc846a4a283d63842.png

Edited by bhtoys

Share this post


Link to post
Share on other sites
  • 0

@bhtoys
are you sure that all options are set correctly (modules -> payment)?

missing image "setup your carrier price range"
second page ????

example: 
modules -> payment

image.thumb.png.39405f396c3b6e590dfdd131c0381a6e.png

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, colorful-ant said:

@bhtoys
are you sure that all options are set correctly (modules -> payment)?

missing image "setup your carrier price range"
second page ????

example: 
modules -> payment

 

Everything you have checked, I also have checked off. 

Share this post


Link to post
Share on other sites
  • 0

send a screenshot of section #2 "Shipping locations & costs"

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, yaniv14 said:

send a screenshot of section #2 "Shipping locations & costs"

Is this what you want? 
image.thumb.png.51fbc46b35433e4940de96b570580fd4.png

Share this post


Link to post
Share on other sites
  • 0

can you put "9999" in "Will be applied when the weight is < "

and also mark "All" and put "0" in the amount column, which will mark all continents and add "0" amount to them.

and than save and see if it works

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Same Error. 

Forgive me. I haven't set stuff up like this in about 6 years. I'm pretty sure I've got everything in the right spot. But is there a walkthrough to set the Carrier section up or something? I can't understand why this isn't working. 

Thank you for taking the time to help me figure it out. 

Edited by bhtoys

Share this post


Link to post
Share on other sites
  • 0

So I just found out that prestashop 1.6 mods can be used with thirty bees.

Any recommendations for a module that will allow me to just pick options for shipping/pick up instead of messing with this?

Share this post


Link to post
Share on other sites
  • 0

I just started having the same problem under TB 1.1.x.  It used to work fine and it was not changed.  But I get this error all the time now.  It is intermittent but more often than not, the error appears.

Share this post


Link to post
Share on other sites
  • 0

I'm convinced this is broken. I've tried everything thus far. 

Are there no modules to simply allow me to put "PICK UP ONLY" as a shipping option.

 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
7 minutes ago, bhtoys said:

I'm convinced this is broken. I've tried everything thus far. 

Are there no modules to simply allow me to put "PICK UP ONLY" as a shipping option.

 

You do not need a module for that - you can do it with the actual system and it works - at least it still does for me for that specific carrier type. And while we are on the subject, it would be cool if the language could be applied to the Carrier Name, because the laws here require that on the French site everything should be in French and the fact that only one name in one language is allowed makes things difficult...

Here is my setup, if it can help you...  Do not use the free shipping, just set the amount to zero.  The free shipping thing is buggy and it yields weird results.  It will appear free to customers anyways.

 

 

Screen Shot 2020-03-31 at 11.38.26 PM.png

Screen Shot 2020-03-31 at 11.38.40 PM.png

Screen Shot 2020-03-31 at 11.38.50 PM.png

Screen Shot 2020-03-31 at 11.38.57 PM.png

Edited by movieseals

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Appreciate the help. Did mine exactly like yours (Can't add my province however?), and got the same error message. 
Beyond frustrated with this thing.

I'd love to become a backer / supporter of it - if it would work.
 

Edited by bhtoys

Share this post


Link to post
Share on other sites
  • 0

Care to give access to your back end so I can take a look?

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
1 hour ago, bhtoys said:

Appreciate the help. Did mine exactly like yours (Can't add my province however?), and got the same error message. 
Beyond frustrated with this thing.

I'd love to become a backer / supporter of it - if it would work.
 

You need to create the province in Localizations>States

It normally works flawlessly - I dunno why things went all wonky this week.  Some was due to PHP 7.3, which might be an issue, some of it I cannot pinpoint yet.

Edited by movieseals

Share this post


Link to post
Share on other sites
  • 0
On 3/30/2020 at 11:20 PM, bhtoys said:

image.thumb.png.844f32f5ebf13bdfc846a4a283d63842.png

From your screenshot above it looks like you don't have associated any delivery zones to your carrier. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, yaniv14 said:

Care to give access to your back end so I can take a look?

PM incoming.

Share this post


Link to post
Share on other sites
  • 0

I started having the same issues lately but I do not have Advanced stock management set.  It used to work fine but intermittently, it will claim that the order is too heavy for the carriers, whereas it is not.  I cannot find what is causing this, as no settings where changed for the carriers in a long time.  

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, datakick said:

Well, the problem was that you enabled Advanced stock management, but didn't associate your products with warehouses.

After I disabled this feature checkout works just fine.

image.png.c01923e347403fa4ad8bf03209135430.png

If you want to use this feature, you need to

  1. create warehouses
  2. associate warehouses with carriers
  3. associate products with warehouses (and locations)

Seriously? That's what it was... sheesh. Thanks a ton man. Very much appreciated. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...