Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Traumflug

thirty bees getting better and better: release 1.0.8

Recommended Posts

@traumflug This seems to have fixed it. However on the Configuration Information page I have 727 obsolete files listed. How do I fix this?

Share this post


Link to post
Share on other sites

These obsolete files were always there, just no tool existed to notice them. Finding obsolete files is also a new feature.

I'd say one can delete them, but I have no idea which kind of files these are. Do you have a few examples?

Share this post


Link to post
Share on other sites

@traumflug The first few: classes/controller/AjaxController.php classes/controller/ModuleAjaxController.php vendor/defuse/php-encryption/.gitignore vendor/defuse/php-encryption/docs/InstallingAndVerifying.md vendor/defuse/php-encryption/docs/Tutorial.md vendor/defuse/php-encryption/docs/CryptoDetails.md vendor/defuse/php-encryption/docs/InternalDeveloperDocs.md vendor/defuse/php-encryption/docs/UpgradingFromV1.2.md vendor/defuse/php-encryption/docs/FAQ.md vendor/defuse/php-encryption/docs/classes/KeyProtectedByPassword.md vendor/defuse/php-encryption/docs/classes/Key.md vendor/defuse/php-encryption/docs/classes/File.md vendor/defuse/php-encryption/docs/classes/Crypto.md vendor/jakeasmith/httpbuildurl/.gitignore vendor/jakeasmith/httpbuildurl/.travis.yml vendor/mrclay/minify/docs/CookBook.wiki.md vendor/mrclay/minify/docs/FAQ.wiki.md

and the last few:

admin/core.20163 admin/core.39049 admin/core.25959 admin/core.50711 admin/php_mail.log admin/core.42184 admin/core.24519 admin/core.10028 admin/core.11685 admin/core.3758 admin/core.43007 admin/core.52205 admin/core.16100 admin/core.44038 admin/core.50973

There are lots of vendor/ files

Share this post


Link to post
Share on other sites

classes/controller/AjaxController.php classes/controller/ModuleAjaxController.php

These two can get deleted. They're no longer in thirty bees.

vendor/defuse/php-encryption/.gitignore vendor/defuse/php-encryption/docs/InstallingAndVerifying.md [...]

Is this a developer installation, perhaps? Or a shop started with a clone from Github? These files aren't necessary either, they should exist in developer installations, only.

admin/core.43007 admin/core.52205 admin/core.16100

These look like core dumps. Files written on fatal errors, only useful for debugging the code. Can go away as well.

It looks a bit like this page needs a delete button behind each file.

Share this post


Link to post
Share on other sites

@traumflug The error page truncated the admin name so yes it is the admin directory. I did a search for core.19283 in cpanel as I didn't have an "admin" folder and it found it in my adminxxxx directory.

Share this post


Link to post
Share on other sites

A deletion ability for the files would be nice.

Seems like most all of the files I see that are obsolete, are of the .md extention.

Share this post


Link to post
Share on other sites

Is there any way you can tell if you site has been upgraded. Mine is still showing 1.0.7 and not really sure I have

Share this post


Link to post
Share on other sites

@andyc if it's showing 1.0.7, then it probably wasn't. Did you encounter any problems during update?

Share this post


Link to post
Share on other sites

Sorry if this sounds stupid , but there are no updates available to run again. Or is this update different to 1.0.7

Share this post


Link to post
Share on other sites

Hence my confusion :) 0_1545175339837_Capture.JPG I know I can change it by follow instructions from 1.0.7 . Which was why I asked if there was somehow I could see if I had

Share this post


Link to post
Share on other sites

Lame way to check if you had been updated - download both 7 and 8 version and run difference comparison tool against the files in the folders, check few files with differences on your server if they are updated. If so then all of them were updated and you got an error just before version update in your config.

Share this post


Link to post
Share on other sites

I'm trying to upgrade my TB 1.0.7 sandbox to 1.0.8 and I'm getting this error:

``` Analyzing the situation...

Testing directories...

Downloading... (this can take a while)

Download complete. Now extracting...

File extraction complete. Now backing up files.

[Ajax / Server Error for action backupFiles] textStatus: "error " errorThrown:" " jqXHR: " "

Archives will come from https://github.com/thirtybees/thirtybees/releases/download/1.0.8/thirtybees-v1.0.8.zip and https://api.thirtybees.com/updates/packs/thirtybees-extra-v1.0.8.zip md5 hashes for core and extra should be resp. 805bf1b9e8ee6abf17e5e32f0b433a9f and cc9ea91c50ea0c2390f2af2a79efbdad Downloads took 0 seconds. "/latest" directory has been emptied Archive /home/nginx/domains/domain.com/public/admin2254x5srx/autoupgrade/download/thirtybees-v1.0.8.zip extracted Archive /home/nginx/domains/domain.com/public/admin2254x5srx/autoupgrade/download/thirtybees-extra-v1.0.8.zip extracted ``` I already read the 1.07 thread where someone got the same error but I can't understand what I need to do to fix it. Manual upgrade?

I can't see error on logs.

The pgrade from 1.0.6 to 1.0.7 went smooth (Debian and php5.6), 1.0.7 to 1.0.8 (CentOS 7 and php 7.1) is giving me that error.

File and Directories permissions are ok: find ./ -type d -exec chmod 755 {} \ ; find ./ -type f -exec chmod 644 {} \;

Share this post


Link to post
Share on other sites

If you have a backup (or a sandbox), turn off the backup during the update. That's just a waste of time.

These errors without message usually get solved by simply reloading the page and trying again. One can run updates over and over again, until it succeeds. Success is indicated by a version change and/or the updater no longer offering an update.

Share this post


Link to post
Share on other sites

Hi,

I had some problems with the upgrade from 1.0.7 to 1.0.8. First attempt. I did not update the module Thirty bees Updater, so the update was based on the version 1.3.4. I got the message: All files upgraded. Now upgrading database ... [Ajax / Server Error for action upgradeDb] textStatus: "error" errorThrown: "Internal Server Error" jqXHR: ""

After 10 minutes I've refreshed site and I got the message:

*thirty bees updater This module keeps your modules updated. Click the button below to force an update check. 500 Server Error**

After another 10 minutes, the system came back to life :).

I made the update of the Thirty bees Updater module and updated TB to 1.0.8 Everything went ok, besides one error message:

SQL 1.0.8 1064 in INSERT INTO tb_configuration (name, value,date_add, date_upd) SELECT 'TBMAILSUBJECTTEMPLATE', '[{shopname}] {subject}', NOW (), NOW ( ) WHERE (SELECT COUNT () FROM tb_configuration WHEREname = 'TB_MAIL_SUBJECT_TEMPLATE') = 0: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE (SELECT COUNT () FROM tb_configuration WHEREname =' TB_M 'at line 3

Can I assume that the system is OK or should I do some additional activities?

Share this post


Link to post
Share on other sites

for that error message see Traumflug 3 days ago

Easier way to fix it:

Go to back office -> Advanced Parameters -> E-Mail
In panel EMAIL (the 2nd) find field Email subject template and insert [{shop_name}] {subject} there.
Click Save.

This is the new feature which allows setting a custom email subject.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×