Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

  • 0
AndyC

Server Move

Question

Hi

Can I ask I am moving my 1 site to another host.

So far I have moved the database by export /import. Uploaded all files ( by FTP) Changed name servers to point to new server and used the correct config settings to look at new server and redone my .htaccess.. But all a is a get is a 500 page on both admin and site. Am I missing something

Share this post


Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0

In general I expect that is has to do with htaccess, did you enable debugging using ftp?

Share this post


Link to post
Share on other sites
  • 0

What server and thirtybees log is showing you?

Share this post


Link to post
Share on other sites
  • 0

If I'm honest no ..As I didn't think it would work .. I'm at work for a while but when I get home I'll try

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
2 minutes ago, pauld said:

What server and thirtybees log is showing you?

I'll have to check that when I get home again.The first time I didn't see anything in ftp log ..I deleted all files and started again thinking it could have been a file upload issue

 

Edited by AndyC

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Finally got onto admin and enabled debug mode .... Have removed my server username for obvious reasons.. But it looks like a missing file but I'm still not home lol so can't check against a backup

 Warning on line 1157 in file /home/domain user name/domains/pewterjewellery.co.uk/public_html/classes/module/Module.php
[2] scandir(/home/domain user name/domains/pewterjewellery.co.uk/public_html/modules/): failed to open dir: No such file or directory

Warning on line 1157 in file /home/domain user name/domains/pewterjewellery.co.uk/public_html/classes/module/Module.php
[2] scandir(): (errno 2): No such file or directory

Warning on line 1158 in file /home/domain user name/domains/pewterjewellery.co.uk/public_html/classes/module/Module.php
[2] Invalid argument supplied for foreach()

Warning on line 1157 in file /home/domain user name/domains/pewterjewellery.co.uk/public_html/classes/module/Module.php
[2] scandir(/home/domain user name/domains/pewterjewellery.co.uk/public_html/modules/): failed to open dir: No such file or directory

Warning on line 1157 in file /home/domain user name/domains/pewterjewellery.co.uk/public_html/classes/module/Module.php
[2] scandir(): (errno 2): No such file or directory

Warning on line 1158 in file /home/domain user name/domains/pewterjewellery.co.uk/public_html/classes/module/Module.php
[2] Invalid argument supplied for foreach()

 

Edited by AndyC

Share this post


Link to post
Share on other sites
  • 0

Looks like modules directory is missing, or has wrong permissions

/home/domain user name/domains/pewterjewellery.co.uk/public_html/modules/

Share this post


Link to post
Share on other sites
  • 0

Thanks... I've deleted modules folder and re-uploading to see 

 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Got though that with modules.. I think... I am now getting these error messages from admin.. I don't have ssl yet ,but disabled it in admin before I got kicked out and trying to buy ..

I was going to try and reload files though putty but for some reason can't access it right now.. Is loading files via FTP OK to do

Under FTP logs getting this message..

ERROR* 	2020/05/01 - 21:51:51: Class 'Module' not found at line 449 in file classes/Hook.php
*ERROR* 	2020/05/01 - 21:52:50: Class 'Hook' not found at line 275 in file config/config.inc.php
Class 'Hook' not found
in file config/config.inc.php at line 275
Source file: config/config.inc.php

256:define('_PS_OS_WS_PAYMENT_', Configuration::get('PS_OS_WS_PAYMENT'));
257:define('_PS_OS_COD_VALIDATION_', Configuration::get('PS_OS_COD_VALIDATION'));
258:
259:if (!defined('_MEDIA_SERVER_1_')) {
260:    define('_MEDIA_SERVER_1_', Configuration::get('PS_MEDIA_SERVER_1'));
261:}
262:if (!defined('_MEDIA_SERVER_2_')) {
263:    define('_MEDIA_SERVER_2_', Configuration::get('PS_MEDIA_SERVER_2'));
264:}
265:if (!defined('_MEDIA_SERVER_3_')) {
266:    define('_MEDIA_SERVER_3_', Configuration::get('PS_MEDIA_SERVER_3'));
267:}
268:
269:// This constant is no longer used anywhere in the core, it exits solely
270:// for retrocompatibility with prestashop modules
271:if (!defined('_PS_CACHE_ENABLED_')) {
272:    define('_PS_CACHE_ENABLED_', Cache::isEnabled());
273:}
274:
275:Hook::exec('actionRegisterAutoloader');
276:Hook::exec('actionRegisterErrorHandlers');

 

Edited by AndyC

Share this post


Link to post
Share on other sites
  • 0

Finally may have fixed it by deleting "cache/class_index.php".. Up and running , by the looks of it although can't add anything to cart ..But it may need time to populate everything , I hope

 

Share this post


Link to post
Share on other sites
  • 0

The cart worked for me in London just now.
I could count to five or six while it loaded one or two of the account-opening pages, but it got as far as Nochex or Paypal without a hitch.
Oddly enough the front of the shop looked OK this time yesterday, but maybe that was the Cloudflare cache.

Share this post


Link to post
Share on other sites
  • 0

@veganline

I've got 2 websites ... Did you create a account for T Test as you may have been on my main site.

Share this post


Link to post
Share on other sites
  • 0

yeah I am just waiting for my SSL certificate now and then it's all go .. If you have a IP address I can get you access to test

Share this post


Link to post
Share on other sites
  • 0

@AndyC with your p..world.co.uk are you targeting UK market?

As website is slow as hell, even if accessed from London.

I suggest to switch hosting, as such slow speed is bad for your business.

 

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, toplakd said:

@AndyC with your p..world.co.uk are you targeting UK market?

As website is slow as hell, even if accessed from London.

I suggest to switch hosting, as such slow speed is bad for your business.

 

I've only just moved lol ,,With Hostinger

Share this post


Link to post
Share on other sites
  • 0

Last time I was moving my shop, I bought about 10 hosting plans for 1 month (within 2 months), installed copy of my shop on each of them, and was testing speed from worldwide locations to every single hosting on daily basis. Until I decided for current one.

For aproximate speed testing I used gtmetrix.com and https://www.dotcom-tools.com/website-speed-test.aspx

I'm currently hosting in Germany and I get pretty good results worldwide compared to the price I pay - 64€ (without tax) yearly for 2vCore 1Gb Ram - cPanel.

Tried caching, cloudflare, keycdn, and with all i get mixed results regarding speed (mostly slower than without anything)

 

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, toplakd said:

I'm currently hosting in Germany and I get pretty good results worldwide compared to the price I pay - 64€ (without tax) yearly for 2vCore 1Gb Ram - cPanel.

Out of curiosity who are you hosted with ... I searched and search .. I can still cancel as I have a 1 month trial ...  

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, AndyC said:

lol All in German , thanks anyway

Personally I'm more on PlanetHoster, it's Canadian, perfroming and an irreproachable support.

Share this post


Link to post
Share on other sites
  • 0

I can upgrade for a similar price and get

Dedicated IP
3 GB RAM
4 GB Burst RAM
4.8 GHz CPUs
40 GB Disk Space
Unlimited Bandwidth
100 MB/S Network
SSD Disk Drives

But need to make some sales. Even here my daily visits are way up compared to my last host

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...