Jump to content

Welcome, Guest!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

Traumflug

thirty bees 1.1.0 Preview

Recommended Posts

14 hours ago, yaniv14 said:

is it possible to add Niara theme to crowdin?

This will happen as part of the release.

And I hope I don't forget to copy community-theme-default translations to Niara, because as far as I can see, they're pretty much the same. Niara is about looking good, so mostly Sass/CSS changes.

Share this post


Link to post
Share on other sites

It should not, no. The main changes are the front office and new theme features. 

Share this post


Link to post
Share on other sites

It should not be compatible or should not break the compatibility?

Because if you update smarty there were controversial opinions if current themes work with the new version you choose. If I remember this was the main issue and you said 1.1 will break some compatibility exactly because of that... Or plans have changed since?

Share this post


Link to post
Share on other sites

It should not break compatibility, but it would be something I would test with a dev site just to be sure. We did not test against the warehouse theme, that developer does not cooperate with our project, so its difficult for us to test with. 

Share this post


Link to post
Share on other sites
Posted (edited)

Yes, I know 'he's too busy making big bucks supporting for 1.7' and does not want to make new item and sell few more licenses for TB.

If the needed changes are small can they come from the comunity? I believe the theme should keep some form of support because together with Panda it's the most used theme for TB.

 

Any plans for beta stage, final release for 1.1?

Edited by the.rampage.rado

Share this post


Link to post
Share on other sites

I am not sure how the community could release a paid theme with fixes. The first step would be to test it to see if it works. I assume it should work fine, but that is just my best guess. 

Share this post


Link to post
Share on other sites
Posted (edited)

If I find time in the following days I'll run few tests.

I mean if there are 2-3 commits of fixes in the theme can this be patched are released in the wild as 'unofficial fix'...

I'm glad that at least Panda's dev is here and support his clients and the project!

Edited by the.rampage.rado

Share this post


Link to post
Share on other sites

I think we need to have one more release before the final, but I will defer to @Traumflug for that 

Share this post


Link to post
Share on other sites
On 6/27/2019 at 7:29 AM, the.rampage.rado said:

I'm glad that at least Panda's dev is here and support his clients and the project!

Aren’t both Warehouse and Panda developed by the same person?

Share this post


Link to post
Share on other sites
Posted (edited)
37 minutes ago, dynambee said:

Aren’t both Warehouse and Panda developed by the same person?

No. Warehouse is deverloped bij IQIT-commerce and Panda by Sunnytoo. Panda and Transformer are developed by the same developer

Edited by vincentdenkspel
  • Thanks 1

Share this post


Link to post
Share on other sites
On 6/26/2019 at 3:40 AM, Jonny said:

@rubben1985 I guess yes, we will make Panda theme v1 to support all new features of TB 1.1.0.

Hi, Jonny,

Don't leave us transformer theme users behind 😕

  • Thanks 1

Share this post


Link to post
Share on other sites

Tried to install it today: Constants may only evaluate to scalar values

I am still on php 5.6 so that may be a problem.

tb110.thumb.jpg.09fbbedf65572afc153faf73c3197fd2.jpg

Something different. Just curious. TB 1.1 has a lot of new hooks. Prestashop 1.7.6 has 200+ new hooks too. Is there any coordination?

image.png

image.png

Share this post


Link to post
Share on other sites

There is no coordination with the hooks. Most of our new hooks are display hooks to make the front office easier to modify and more effective. 

 

I think either @datakick or @Traumflug would be better to answer the 5.6 question, but I do not see a real need in supporting it anymore with the 1.1.x branch. 

Share this post


Link to post
Share on other sites
56 minutes ago, musicmaster said:

Tried to install it today: Constants may only evaluate to scalar values

 I am still on php 5.6 so that may be a problem.

This problem is already fixed. If you want to continue testing, replace the `define` with `const`, as shown here

Share this post


Link to post
Share on other sites
14 hours ago, musicmaster said:

...I am still on php 5.6 so that may be a problem....

I faced the same problem. For me tb v1.1.0 works fine with php in version range 7.0 to 7.2 (Fresh installation && all php settings were set according to tb recommendations, MariaDB 10.3) 

With php v5.6 lot of notices && warnings, with php v7.3.5 I couldn't enter to BO (with php v7.3 still looking possible issue on my side - maybe I missed something).

Edit: Anyway - great work guys

Edited by PepeLopez

Share this post


Link to post
Share on other sites

Modules and themes catalog is empty. How can I add translation ? I have translataion for community-default. How can I add community-default theme. It's present when i look via FTP, but how to "activate" this ?

EDIT: Got it.

Edited by led24ee

Share this post


Link to post
Share on other sites

When I install the pre1.1 and I want to have the latest fixes on GIT... I thought I could use the CoreUpdater module set to bleeding edge. This seems not to be the case. Why?

 

Share this post


Link to post
Share on other sites

This is because bleeding edge is mirroring 1.0.x branch, while 1.1.0 pre-release is based on 1.1.x branch. That means that bleeding edge will give you only bugfixes implemented since from 1.0.8. New features or other 1.1.0 specific commits are in 1.1.x branch only.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×